Server crashes after adding bots

General Support & Discussion related to Half Life 2 games including Counter Strike Source, Day of Defeat Source, and Half Life 2 Deathmatch.
Post Reply
troublesh0t
GameServers.com Forum Newb
Posts: 1
Joined: Tue Apr 07, 2015 2:25 pm

Server crashes after adding bots

Post by troublesh0t » Thu Apr 09, 2015 11:08 pm

Hi All. My CSS:DM server crashes almost instantly after adding bots. Everything runs fine(although nobody plays on server). The second I issue a command to add even a single bot the server crashes. If i edit the dm.cfg file the server crashes as soon as a player joins and bots populate server. I must admit I am new to this and would greatly appreciate the help.

The console output is:
L 04/10/2015 - 03:36:00: [funcommands.smx] "SHAZBOT<2><STEAM_0:1:382209><>" ignited "SHAZBOT<2><STEAM_0:1:382209><>" (seconds "20.000000")
L 04/10/2015 - 03:36:04: [funcommands.smx] "SHAZBOT<2><STEAM_0:1:382209><>" ignited "SHAZBOT<2><STEAM_0:1:382209><>" (seconds "20.000000")
L 04/10/2015 - 03:36:12: [playercommands.smx] "SHAZBOT<2><STEAM_0:1:382209><>" slayed "SHAZBOT<2><STEAM_0:1:382209><>"
Game will not start until both teams have players.
PreMinidumpCallback: updating dump comment
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/assert_20150409040012_1.dmp
/usr/local/games/css/1197748/68.232.160.122:27035/css/wrapper.sh: line 2: 2803 Segmentation fault /home/glibc215/lib/ld-linux.so.2 --library-path /home/glibc215/lib/:bin/:. ./srcds_linux $*
[OVERLORD] ERROR Server has died, return code 139
[OVERLORD] INFO Starting server
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-f98720d0-1902-43aa-a2ee-3316e2150409
Using breakpad minidump system
Using breakpad crash handler

User avatar
hermanray
No Longer a Newb
Posts: 88
Joined: Thu Mar 26, 2015 11:57 am

Re: Server crashes after adding bots

Post by hermanray » Wed Apr 15, 2015 1:05 pm

[OVERLORD] ERROR Server has died, return code 139
I couldn't find at all what return code 139 means but think that might have caused the issue for you.

generalspace
GameServers.com Forum Newb
Posts: 1
Joined: Mon Jul 20, 2015 4:57 am

Re: Server crashes after adding bots

Post by generalspace » Mon Jul 20, 2015 5:02 am

I think its game servers I am going to build a new server on a different server co. and see if I get some error.

PreMinidumpCallback: updating dump comment
assert_20150719220840_1.dmp[24976]: Uploading dump (out-of-process)
/tmp/dumps/assert_20150719220840_1.dmp
assert_20150719220840_1.dmp[24976]: Finished uploading minidump (out-of-process): success = no
assert_20150719220840_1.dmp[24976]: error: libcurl.so: cannot open shared object file: No such file or directory
assert_20150719220840_1.dmp[24976]: file ''/tmp/dumps/assert_20150719220840_1.dmp'', upload no: ''libcurl.so: cannot open shared object file: No such file or directory''
/usr/local/games/css/1219942/107.191.48.171:27025/css/wrapper.sh: line 2: 24467 Segmentation fault /home/glibc215/lib/ld-linux.so.2 --library-path /home/glibc215/lib/:bin/:. ./srcds_linux $*
[OVERLORD] ERROR Server has died, return code 139

munguiatom
GameServers.com Forum Newb
Posts: 7
Joined: Thu Sep 03, 2015 9:41 pm

Re: Server crashes after adding bots

Post by munguiatom » Wed Oct 07, 2015 9:48 pm

same thing is happening with my game server. How did you fix this problem? I'm not getting any error message in console. my game server is running all updated mods (sourcemod, metamod, deathmatch)

[gs] kad
GameServers Staff
Posts: 1086
Joined: Mon Sep 05, 2005 9:52 pm
Location: Los Angeles
Contact:

Re: Server crashes after adding bots

Post by [gs] kad » Fri Oct 09, 2015 12:39 am

Make sure you guys send in a Support ticket so we can look into the issues for you.

I can tell you that when you see "Segmentation fault" errors, it relates to Mods you have running so you may want to recheck what you added addon wise.
David Palmer
https://gameservers.com/

follow us on twitter - http://twitter.com/gameservers_com

munguiatom
GameServers.com Forum Newb
Posts: 7
Joined: Thu Sep 03, 2015 9:41 pm

Re: Server crashes after adding bots

Post by munguiatom » Fri Oct 09, 2015 9:13 pm

I do support ticket but it takes hours before you guys respond. Use to be quick now its really long and slow for you to respond.

Post Reply