Page 1 of 1

ETPUB 1.0.0 and 0.9.1 not working, how to fix, and install "glibc" and "libstdc++6"?

Posted: Sat Sep 16, 2017 9:08 am
by bigjoe
First off let me say I'm on Windows 10 and have no access to any linux terminal/PC/server/SSH, just FTP.

I need help getting the latest etpub 1.0.0 from 2013 onto my friend's server with FTP.

The one that says 565 next to it, or whatever the latest "revision" is.
https://app.assembla.com/spaces/etpub/subversion/source

Also, and this might be more important...I need help getting etpub 0.9.1/1.0.0 to work at all.
Yes, I put the "qagame.mp.i386.so" in the etpub folder. Still didn't work like it should. I tried this 1.0.0 - http://www.wolffiles.de/index.php?filebase&fid=4523 - and this 0.9.1 - https://app.assembla.com/spaces/etpub/documents

Neither worked, and yes I did put the lua.so file(s) next to the etded file.

Here's the error I get when I try to start up my friend's server with etpub 1.0.0/0.9.1 -------------

"libstdc++.so.6: cannot open shared object file: No such file or directory"

So, after maybe 5 or 10 minutes googling, I found this -
https://packages.ubuntu.com/trusty/i386 ... 6/download
and these inside -
https://i.imgur.com/rqfojBP.png

So I put both of them in the same folder where my etded is located, and got this new error:
"/lib/libc.so.6: version `GLIBC_2.18' not found (required by ./libstdc++.so.6)"

So, I googled and found this -
https://launchpad.net/ubuntu/trusty/i38 ... 8-0ubuntu6
and these inside -
https://i.imgur.com/5C2Zg8B.png
The ones in the red box are what I added to the folder where etded is, and, well...

Same error, all over again.

"/lib/libc.so.6: version `GLIBC_2.18' not found (required by ./libstdc++.so.6)"


So, how do I fix all of this, with only FTP?

Re: ETPUB 1.0.0 and 0.9.1 not working, how to fix, and install "glibc" and "libstdc++6"?

Posted: Mon Sep 18, 2017 11:53 am
by bigjoe
Still not fixed at the moment.

Re: ETPUB 1.0.0 and 0.9.1 not working, how to fix, and install "glibc" and "libstdc++6"?

Posted: Wed Sep 20, 2017 6:45 pm
by [gs] kad
Please make sure you open a ticket with the issues you're having. We may have to move you to another machine in order to have these mods work properly.